1. downloads
  2. business software
  3. news
  4. reviews
  5. top apps
Download TeamSpeak Server 3.0.5 (64-bit)

TeamSpeak Server 64-bit 3.0.5

By TeamSpeak Systems GmbH  (Non-Commercial Freeware)
User Rating
Advertisement

TeamSpeak is flexible, powerful, scalable software which enables people to speak with one another over the Internet. TeamSpeak consists of both client and server software. The server acts as a host to multiple client connections, capable of handling literally thousands of simultaneous users.

  • Address book for easier management of multiple TeamSpeak servers
  • Create multiple channels and sub-channels for your users
  • Moderate channels for more control when hosting large group meetings
  • Whisper functions so you can speak privately to inidividuals, groups of persons, or users in other channels

This is the 64-bit version of the server.

Title: TeamSpeak Server 3.0.5 (64-bit)
Filename: teamspeak3-server_win64-3.0.5.zip
File size: 4.59MB (4,813,018 bytes)
Requirements: Windows XP 64-bit / Vista 64-bit / Windows 7 64-bit / Windows 8 64-bit / Windows 10 / Windows 10 64-bit
Languages: Multiple languages
License: Non-Commercial Freeware
Date added: April 24, 2012
Author: TeamSpeak Systems GmbH
www.teamspeak.com
MD5 Checksum: FF7578084CE96C417650F525DDBD3A9F

- MySQL users, please alter your table server_properties and extend the "value" field from varchar(255) to varchar(2048)
- privilegekeylist no longer shows groups which does not match i_group_needed_member_add_power and/or i_group_member_add_power
- added possibility to give a channel password when creating a temporary server password (check docs for details)
- the following actions will reset client idletime:
> logview, clientdblist, complainlist, complainadd, talkower grant and revoke
- clientlist can also show ips (paramter -ip)
- fixed an issue were channel properties saved two times on create or edit
- fixed an issue were clientdbdelete did not delete avatar files correctly
- fixed invalid ident names for virtualserver_antiflood_points_needed_command_block and virtualserver_antiflood_points_needed_ip_block (breaks client-side serveredit below version 3.0.6)

blog comments powered by Disqus